freks blog

about

Gatsbyjs v2 から v3 へアップグレードした

このブログは Gatsbyjs v2 を使っていましたが、v3 へアップグレードしてみました

アップグレード内容はこちら
Gatsby v3 Incremental Builds in OSS, new Gatsby Image, and more | Gatsby

アップグレードの仕方はこちら
Migrating from v2 to v3 | Gatsby

このブログはほとんどデフォルトだったのでソースコードを変えるところはありませんでした

ただ、CircleCI で、cypress-io/cypress@1.27.0 orb を使っていて、それが Node 10 で動いていたのでエラーになっていました
Gatsbyjs v3 は Node 12.13.0 以降が必要です

Node 14 で動くように変更でクリアしました 変更箇所

あと Windows10 WSL2 使っていたのですが、/mnt/c 以下だと Gatsbyjs がインストールされてないとかでエラーになって謎でしたが、ディレクトリ移動すると動きました

gatsby developなどがだいぶ早くなっていい感じです