freks blog

「Warning: React version not specified in eslint-plugin-react settings.」を解決する

このブログはGatsbyで作ってるんですが、eslintをかけるとWarningエラーがでました

解決したときのバージョン

"gatsby": "2.0.118",
"eslint": "5.13.0",
"eslint-plugin-react": "7.12.4",

eslintをかけると

$ ./node_modules/.bin/eslint src
Warning: React version not specified in eslint-plugin-react settings. See https://github.com/yannickcr/eslint-plugin-react#configuration .

と、Warningが出てるのに気づきました
リンク先を見てもよくわからないので、調べると解決するには

$ vim .eslintrc.json

  "settings": {
    "react": {
      "version": "detect"
    }
  },

を指定するのがよさそうでした
これでWarningでなくなりました

参考にしたリンク